Apple Watch vont bientôt cesser de maintenir les anciennes applications

Dans la version bêta watchOS 4.3.1 recevez un message d’avertissement que, bientôt, la montre ne sera pas ouvrir l’application, qui ont été conçus pour watchOS 1.0, écrit Appleinsider.


Apple Watch vont bientôt cesser de maintenir les anciennes applications

Lors de l’ouverture de la vieille application qui depuis longtemps n’a été mis à jour, une notification s’affiche que des programmes seront bientôt compatibles avec la plate-forme. Apple met également en garde les développeurs, afin qu’ils mis à jour les applications pour une meilleure compatibilité.

Après avoir cliqué sur le bouton «OK», l’application s’ouvre et travailler normalement. Sur cette base, on peut conclure que watchOS 4.3.1 sera compatible avec les anciennes applications, contrairement aux versions futures. Vraisemblablement, l’abandon des anciennes programmes se produira avec la sortie de watchOS 5 de la WWDC 2018.

Apple Watch vont bientôt cesser de maintenir les anciennes applications

En novembre 2017, Apple a cessé de publier sur l’App Store des applications qui ont été conçus pour watchOS 1. Depuis le premier avril, les développeurs doivent utiliser le SDK pour watchOS 2 et ci-dessus, pour la société a publié une application dans le magasin.

Similaire l’avis a été dans iOS 10. Alors Apple a mis en garde les utilisateurs, que les applications 32 bits ne fonctionnent pas dans iOS 11, si les développeurs ne mettent pas à jour de leur.


Suivez l’actualité d’Apple dans notre Telegram-canal, ainsi que dans l’annexe MacDigger sur iOS.

Leave a Reply

Your email address will not be published.


*